MPS issue job003592

TitleALIGN and ALIGN_UP macros are poorly named
Assigned userGareth Rees
DescriptionChristan Schafmeister reported in IRC that "I only found one error in the docs so far. In the Scheme example - obj_pad function - change ALIGN to ALIGN_UP"
AnalysisThese macros are poorly named, making it hard to remember what they do, and therefore hard to check that the right one has been used.

ALIGN_UP rounds a size up to the next multiple of the machine word size. ALIGN does the same, but in addition makes sure that the returned size is big enough to store a forwarding pointer.

Maybe ALIGN_WORD and ALIGN_OBJ? Any better suggestion?
How foundcustomer
EvidenceIRC #memorypoolsystem 2013-08-12 15:22
Observed in1.111.0
Introduced in1.111.0
Created byGareth Rees
Created on2013-08-12 15:32:02
Last modified byGareth Rees
Last modified on2013-09-05 08:15:56
History2013-08-12 GDR Created.


Change Effect Date User Description
183392 closed 2013-09-05 08:15:56 Gareth Rees Rename ALIGN_UP and ALIGN macros in the Scheme example as ALIGN_WORD and ALIGN_OBJ respectively.