MPS issue job003833

Title"Arena alignment" is a misleading name
Assigned userGareth Rees
DescriptionThe code uses "alignment" to mean "grain of arena allocation". This name is misleading: the value is not actually an alignment (though we insist that it is a power of two for performance reasons in the tract lookup calculation).

Moreover, the confusion between the "arena alignment" and ordinary structure alignment makes functions that have to deal with both very hard to write clearly, such as the client and VM arena implementations.
AnalysisRename "arena alignment" to "arena grain size" or "grain" for short.
How foundinspection
Created byGareth Rees
Created on2014-06-11 15:00:40
Last modified byGareth Rees
Last modified on2014-06-13 15:34:32
History2014-06-11 GDR Created.


Change Effect Date User Description
186573 closed 2014-06-13 15:34:32 Gareth Rees Merge branch/2014-06-11/grain into the master sources.