MPS issue job003835

TitleSegPrefs are poorly named
Assigned userGareth Rees
DescriptionSegPref objects express a preference for the placement of addresses within an address space. The name is misleading: any address may be placed according to a SegPref, not just a segment.

NB says [1]: "Should SegPrefs be called something else now?"
AnalysisRename them. To what?

Also, there needs to be a Describe function.
How foundinspection
Evidence[1] <>
Created byGareth Rees
Created on2014-06-12 15:40:23
Last modified byGareth Rees
Last modified on2014-09-27 11:27:00
History2014-06-12 GDR Created.


Change Effect Date User Description
187061 closed 2014-09-27 11:27:00 Gareth Rees Rename SegPref to LocusPref -- this structure describes preferences for the placement of any kind of address, not just segments.
Add LocusPrefDescribe and use it in MVFFDescribe.